[one-users] vOneCloud Issue

Javier Fontan jfontan at opennebula.org
Fri Dec 12 08:18:09 PST 2014

Yes, the templates should appear in the OpenNebula web interface. Just to

* You executed all commands as oneadmin user
* Ran onevcenter hosts to import the datacenter, this created a new host
(using CLI you can execute "onehost list" to show hosts)
* Ran "onevcenter templates" and after answering "y" when asked to process
datacenter MyQADC it exited to the prompt

"onevcenter templates" command should ask to import each template, here is
an example:

Do you want to process datacenter Testing [y/n]? y

  * VM Template found:
      - Name   : vOneCloud-1.0-template
      - UUID   : 4218450e-becc-b2f5-c1b5-ba0bd47030fa
      - Cluster: Testing
    Import this VM template [y/n]? y
    OpenNebula template 7 created!

Did you have any of those prompts? Are there any templates in that
datacenter? In case you didn't get the prompts an there are templates in
the datacenter you can try executing the command as this to get more
information in case there is an error importing them:

ruby -wd /usr/bin/onevcenter templates --vcenter <your vcenter> --vuser
<your user> --vpass <your password>

It would also be nice if you send us the files /var/log/one/sunstone.* to
check for any problems.

As a side note I was able to use special characters in the cli when put
inside single quotes, for example: 'password@#$%&/()'

On Fri Dec 12 2014 at 3:58:14 PM Savage, Adam <Adam.Savage at monster.com>

> I think I may have found the issue.. When I ran the ruby command from the
> console it complained about my password for my VC account it didn’t like
> the special charectars !@#$ in the password. I created a local account on
> the vcenter server with no special charectars and it started rolling
> through all my vCenter VMs - took about 10 minutes (theres 2500 VMs in that
> vcenter) at the end it prompted me with "Do you want to process Datacenter
> MyQADC [y/n]?" I said yes and then it went to the prompt.. I assume it
> worked? Lol..
> Should the templates just appear in the portal or is there something else
> that needs to be done to import them in? I'm very much a newb to
> OpenNebula..
> Adam Savage | Principal VMware Systems Engineer
> -----Original Message-----
> From: Tino Vazquez [mailto:cvazquez at opennebula.systems]
> Sent: Friday, December 12, 2014 9:54 AM
> To: Savage, Adam
> Cc: Jaime Melis; OpenNebula Users
> Subject: Re: [one-users] vOneCloud Issue
> Hi Adam,
> We just tried your setup (3 level deep in folder templates with
> underscores) but couldn't reproduce the error. We'll wait for the
> requested output.
> Thanks a lot for your feedback,
> -Tino
> --
> OpenNebula - Flexible Enterprise Cloud Made Simple
> --
> Constantino Vázquez Blanco, PhD, MSc
> VP of Engineering | Head of Research at OpenNebula Systems
> cvazquez at OpenNebula.Systems | @OpenNebula
> --
> Confidentiality Warning: The information contained in this e-mail and any
> accompanying documents, unless otherwise expressly indicated, is
> confidential and privileged, and is intended solely for the person and/or
> entity to whom it is addressed (i.e. those identified in the "To" and "cc"
> box). They are the property of OpenNebula.Systems S.L..
> Unauthorized distribution, review, use, disclosure, or copying of this
> communication, or any part thereof, is strictly prohibited and may be
> unlawful. If you have received this e-mail in error, please notify us
> immediately by e-mail at abuse at opennebula.systems and delete the e-mail
> and attachments and any copy from your system. OpenNebula's thanks you for
> your cooperation.
> This message, and any attachments, contain(s) information that may be
> confidential or protected by privilege from disclosure and is intended only
> for the individual or entity named above. No one else may disclose, copy,
> distribute or use the contents of this message for any purpose. Its
> unauthorized use, dissemination or duplication is strictly prohibited and
> may be unlawful. If you receive this message in error or you otherwise are
> not an authorized recipient, please immediately delete the message and any
> attachments and notify the sender.
> _______________________________________________
> Users mailing list
> Users at lists.opennebula.org
> http://lists.opennebula.org/listinfo.cgi/users-opennebula.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opennebula.org/pipermail/users-opennebula.org/attachments/20141212/e9186b9d/attachment.htm>

More information about the Users mailing list