[one-users] sunstone in 3.9.90

Alexandre Bezroutchko abb at gremwell.com
Fri Apr 19 16:37:24 PDT 2013


Similarly to Tao Crain, I also have problems with Sunstone in 3.9.90,
here is my story.

I try it on fresh install of Debian Squeeze, installed from
Debian-6.0.7-opennebula-3.9.90.tar.gz tarball. When I log as oneadmin
there are not tabs under 'Infrastructure', no 'System' tab at all, etc.

In settings I see language set to 'Catalonian' and while there is a
choice of other languages when I try to change it has no effect. GUI is
actually in English anyway.

In settings in "view" I only see "user", there is no "admin". I have
found only one way to see (part of) 'admin' interface -- edit
/etc/one/sunstone-views.yaml and add 'admin' to the default section. But
even then, only 'Host' appears under 'Infrastructure' and 'Groups' and
'ACLs' under System (no 'Users').

There still no way to do anything with images or templates via GUI. I
can download an image from the marketplace, and 'oneimage list' shows it
is there, but there is nowhere to see it the GUI.

I checked the list of open bugs for 4.0 and find nothing similar. I've
tried to install from sources from git (release-4.0-rc tag) -- still
does not work.
Can anyone please tell me if there is any way to resolve these issues in
the immediate future? Otherwise Sunstone don't seem to be usable at all.

Best regards,

More information about the Users mailing list