[one-users] OpenNebula SSH Problem ?

Clément Berthelot mentcle at gmail.com
Tue Oct 18 14:53:10 PDT 2011

Hey guys,

I'm working on my master thesis which has for subject the evaluation of virtual firewall in cloud environment. In this optic, I'm trying to create my own cloud with Xen and OpenNebula. Both the machines I use (Frontend and Node) runs OpenSUSE 11.4. I followed very closely the documentation on how to install OpenNebula(2.2), but after an entire afternoon and no success, I'm turning to you guys.

Almost everything is working: I can access sunstone from any host, the oneadmin account and home directory is successfully on both machines (my frontend is a NFS server) with the same UID/GID. However, when I link the node to the frontend with the onehost command, the node appears but with an 'ERROR' status. I did edit the oned.conf file with the Xen-related options and everything. So when I tried to figure why it was not working, I realized I couldn't connect from the frontend to the node with SSH (connection closed immediately by the node). This is really weird because it works perfectly the other way around (from the node to the frontend) not asking for any password or anything, which means that the problem does not come from the SSH Key/permissions.

I deactivated the firewall on the node, and restarted plenty of times sshd, but it's still not working. I realized Ruby was not installed, and even if I didn't think it would have something to do with SSH, I installed it and tried again for the same result. I really have no clue where this is coming from. Do you guys have any idea ?



More information about the Users mailing list