[one-users] VMs stuck in pending state

Daniel.MOLDOVAN at cs.utcluj.ro Daniel.MOLDOVAN at cs.utcluj.ro
Wed Nov 17 08:00:37 PST 2010


Maybe there is a problem with the host. Onehost top/show does not indicate
an error on the host monitoring side? I am indicating this because
deployement.0 or disk.0 are created when the virtual machine is deployed
on a host(in prolog state). And have you tried to do a force deploy using
"onevm deploy vm_id host_id"? Because maybe you are using onevm create
(not "onevm submit") and the scheduler does not deploy the virtual machine
by itself.

I hope i haven't indicated things that you already have tried, but nothing
else comes to mind. A VM should work event if no network is specified for
it, so i think that the network bridge does not influence this.

Also, because the oned.log usually grows up fast you may try to delete the
one.db( and all other folders  ) from /var/lib/one and the logs from
/var/log/one and try a clean test. Add a host, see if it is monitored ok
and then do a onevm submit and onevm deploy


> Hi,
>> 1. Where is the OS section of the virtual machine template?
> Indeed, there isn't one! I was blindly following the tutorial in
> http://opennebula.org/documentation:rel2.0:vmg and the example given had
> no OS section... anyways I added one now.
>> 2. What hypervisor are you using? With XEN the virtual machine might
>> not boot if the xen kernel was not loaded .
> I'm using KVM.
>> I am particularly using KVM so something like this is in my virtual
>> machine template:
>> NAME   = vm-example
>> CPU    = 0.5
>> MEMORY = 512
>> OS     = [
>> boot = hd, ROOT = hda
>> ]
>> DISK   = [
>> type = disk, clone=no, size = 1024, format = ext3, source=
>> "/home/oneadmin/Desktop/vm/disk.0",
>> target   = hda, readonly = "no" ]
> Thank you Daniel. I tried using your template and just changing the
> source path, but I'm still facing the same problem.
> One thing I noticed though is that in the node /var/lib/one/ has no
> sub-directories with VM ids. There is no images/deployment.0 or disk.0
> created? I wonder why? The oned.log still doesn't signal anything
> unusual.
>> As for the network, i am using the "virbr0" bridge created by the
>> opennebula express install, not eth0.
> How did you manage to use virbr0? did you make any changes to what was
> done by default by opennebula? I can see the bridge virbr0 added to both
> the frontend and node, but both have this same IP
> Thank you.
> --
> Zaina
> _______________________________________________
> Users mailing list
> Users at lists.opennebula.org
> http://lists.opennebula.org/listinfo.cgi/users-opennebula.org

More information about the Users mailing list