[one-users] VMs stuck in pending state

Zaina AFOULKI zaina.afoulki at ensi-bourges.fr
Wed Nov 17 06:55:04 PST 2010


> 1. Where is the OS section of the virtual machine template?
Indeed, there isn't one! I was blindly following the tutorial in
http://opennebula.org/documentation:rel2.0:vmg and the example given had
no OS section... anyways I added one now.

> 2. What hypervisor are you using? With XEN the virtual machine might not
> boot if the xen kernel was not loaded .
I'm using KVM.

> I am particularly using KVM so something like this is in my virtual
> machine template:
> NAME   = vm-example
> CPU    = 0.5
> MEMORY = 512
> OS     = [
>    boot = hd,
>    ROOT = hda
>    ]
> DISK   = [
>    type = disk,
>    clone=no,
>    size = 1024,
>    format = ext3,
>    source= "/home/oneadmin/Desktop/vm/disk.0",
>    target   = hda,
>    readonly = "no"
>    ]

Thank you Daniel. I tried using your template and just changing the source
path, but I'm still facing the same problem.

One thing I noticed though is that in the node /var/lib/one/ has no
sub-directories with VM ids. There is no images/deployment.0 or disk.0
created? I wonder why? The oned.log still doesn't signal anything unusual.

> As for the network, i am using the "virbr0" bridge created by the
> opennebula express install, not eth0.

How did you manage to use virbr0? did you make any changes to what was
done by default by opennebula? I can see the bridge virbr0 added to both
the frontend and node, but both have this same IP

Thank you.


More information about the Users mailing list