[one-users] Problems accessing the VMs

Leonardo Bergesio leonardo.bergesio at i2cat.net
Wed Nov 17 05:42:54 PST 2010


I'm having problems when creating a VM in OpenNebula. I have tried with 
several images (the ttylinux was first) but, even OpenNebula says it is 
running then there is no way no access the machine, I can´t ping the IP 
that OpenNebula informs me that my VM has. On the other hand, the los 
oned.log and vm.log are correct. I tried to create the ttylinux vm 
directly in xen and i wasn´t able because some problem when mounting the 
file system so I supposed maybe the same problem was going on on 
OpenNebula. Next thing I did was creating a VM directly in Xen with the 

xen-create-image --hostname<hostname>  --ip<ip>  --scsi --vcpus 1 --pygrub --dist lenny -c

this way xen itself downloads some disk images (disk.img and swap.img) 
and it goes perfect, I can acces to the machine through the console and 
check its IP and then ssh it. So I tried to use those images and create 
the VM using Open Nebula with the following template:

NAME   = xenu
CPU    = 0.1
MEMORY = 128

OS = [
   kernel   = "/boot/vmlinuz-2.6.26-2-xen-686",
   initrd   = "/boot/initrd.img-2.6.26-2-xen-686",
   root     = "sda1",

DISK   = [
    source   = "/srv/cloud/images/xenu/disk.img",
   target   = "sda",
   readonly = "no" ]

DISK = [
  type     = swap,
  size     = 512,
  source ="/srv/cloud/images/xenu/swap.img",
  target   = "sdb",
  readonly = "no" ]

NIC    = [ NETWORK = "Small network" ]

FEATURES=[ acpi="no" ]

The network template is:

NAME = "Small network"

#Now we'll use the cluster private network (physical)
BRIDGE = eth0
LEASES = [ MAC="00:16:3e:01:02:03", IP=""]
LEASES = [ MAC="00:16:3e:01:02:30", IP=""]
LEASES = [ MAC="00:16:3e:01:02:33", IP=""]

The IPs are public.

It all goes well but the same problem happens again, there is no way to 
acces the VM and the logs show no error. Anyone went through something 

More information about the Users mailing list