[one-users] FW: VM reboot

Harsha Buggi Harsha_Buggi at mindtree.com
Fri Jul 3 18:56:19 PDT 2009


I have also found that the restores are not consistant. Somtimes it goes through if the VM is in pre-boot state when it is deployed. I have tried with this another image which is only 20 MB with Unix like OS. This image did not have any problem with restoring. So now I feel my setup is ok and the problem might be with qemu or libvirt. Has anybody ever face this issue? I am a newbie so would appreciate if responses are a more descriptive.


From: Harsha Buggi
Sent: Thursday, July 02, 2009 10:43 PM
To: Javier Fontan
Subject: RE: [one-users] VM reboot

Hi Javier,

     Thanks for the clarification.

     I am facing another issue in that I am not able to restore images which have been 'stopped' or 'suspended'. I have configured NFS as the transfer manager and am running the entire setup on fc8(client and server).

     I first create an image using virt-manager by connecting to KVM hypervisor. Then I use this image in my configuration file along with 'Clone' option to create VM's. This is an isolated setup so I am running all machines with 'root' user. I do not have 'oneadmin' user or NIS server running in my setup. The VM's boot up without any problems. They also generate the 'checkpoint' file and go to 'susp' or 'stop' state. But when I try to 'resume' them - they fail. I logs say qemu error and libvirt could not restore from the file(I do not have the exact log file right now but I can send this if you need it). I am trying to deploy  Windows XP and a fc8 image files.

    But I am not facing this issue if I deploy my VM's using ssh as the transfer method.

    Is there any work around for this problem?

    I have also found another issue in that I wasnt able to use KVM hypervisor on fc8 as the 'emulator' parameter generated in the VM config file was pointing to 'usr/bin/kvm'. But on fc8 this file is  named 'qemu-kvm' and not 'kvm'. I made this modification in 'libvirtdriver.cc' file and recompiled and things started working thereafter.

   I 'one' server version I am running is 1.2.1.


From: users-bounces at lists.opennebula.org [users-bounces at lists.opennebula.org] On Behalf Of Javier Fontan [jfontan at fdi.ucm.es]
Sent: Thursday, July 02, 2009 4:42 PM
To: Harsha Buggi
Cc: users at lists.opennebula.org
Subject: Re: [one-users] VM reboot


On Jul 1, 2009, at 2:56 PM, Harsha Buggi wrote:
>  I have installed and run OpenNebula and found that there is no
> mechanism to reboot a VM. I have tried 'Onevm shutdown' stops the VM
> and deletes it.
>  'Stop', 'Suspend, and 'Resume' dont just save the VM in its current
> working state but do not reboot the VM.
>  Is there any workaround for this. If this is a bug, when can we
> expect a patch to be released?

We don't have a way to restart Virtual Machines right now but you can
imitate a reboot with this setup:

  * NFS shared images directory
  * Images that hold filesystems use CLONE=no

This way the VM will always use the same image file. Now you can
shutdown and create machines to imitate a reboot.


Javier Fontan, Grid & Virtualization Technology Engineer/Researcher
DSA Research Group: http://dsa-research.org
Globus GridWay Metascheduler: http://www.GridWay.org
OpenNebula Virtual Infrastructure Engine: http://www.OpenNebula.org

Users mailing list
Users at lists.opennebula.org


More information about the Users mailing list