[one-users] Failure warnings with Xen + shutdown

Javier Fontan jfontan at fdi.ucm.es
Mon Feb 16 05:54:19 PST 2009

Hello Niraj,

On Feb 14, 2009, at 1:48 AM, Niraj Tolia wrote:

> When I run "onevm shutdown", I get the following error in oned.log
> Fri Feb 13 15:40:39 2009 [VMM][D]: Message received: SHUTDOWN FAILURE
> 11 Domain 'one-11' does not exist.
> I initially thought I was getting this error because I was using
> xen-unstable but when I started looking through the code, I saw this
> snippet in one_vmm_xen.rb
> std_action("SHUTDOWN", "shutdown #{args[3]} \\&\\& sleep 10 \\&\\&
> sudo #{XM_PATH} destroy #{args[3]} \\&\\& sleep 4", args)
> If 'xm shutdown' suceeds, xm destroy should return an error as the
> domain doesn't exist anymore. This can probably be easily fixed by
> replacing the command with something like 'xm shutdown -w <arg> || xm
> destroy <arg>' .

You are so right, sorry about it. The reason for this shutdown-sleep- 
destroy-sleep is that in our installation (Xen 3.2) we hit a bug. When  
you have a SMP machine and you configure Dom-0 to use only one CPU  
machines are not deleted after shutdown so we let some time for the  
shutdown, destroy the machine, and after that we let some seconds for  
the hypervirsor to close the image and let use move or delete it.

If you do not have the problem with shutdown doing "xm shutdown -w  
<arg>" should be enough. We are doing a major rewrite of the drivers  
for the next release (1.4) so it is easier to maintain and add  
configuration options so both configurations coexist.

Let me know if that change worked for you.


Javier Fontan, Grid & Virtualization Technology Engineer/Researcher
DSA Research Group: http://dsa-research.org
Globus GridWay Metascheduler: http://www.GridWay.org
OpenNebula Virtual Infrastructure Engine: http://www.OpenNebula.org

More information about the Users mailing list