[one-users] Build system problems searching for xmlrpc library

José Miguel Parrella Romero jparrella at onuva.com
Tue Sep 30 11:19:34 PDT 2008

Hash: SHA1

Javier Fontan escribió, en fecha 30/09/08 11:58:
> There have been lots of problems with the build system when it tries to
> figure out the correct parameters to compile/link with xmlrpc. We have
> been improving the script that searches for that parameters and now it
> tells more information when it can not compile test programs. There are
> also log files created in .xmlrpc_test directory that you can use to
> check what went wrong and eventually sending those files to de mailing
> list so we can add more recipes to build OpenNebula in your distribution.


I wanted to try OpenNebula recently in Debian Lenny, and had lots of
problems trying to build it from source. I tried r98 and the 1.0 release
and had to do some additional steps to get it to build:

a) Install the following Debian packages: ruby libsqlite3-0 sqlite3
libsqlite3-dev libsqlite3-ruby libxmlrpc-c3-dev libxmlrpc-c3 scons
libwww-dev zlib1g-dev libexpat1-dev libcurl-dev libcurl4-gnutls-dev

Both libwww0 and libwww-dev were not in Lenny ATM I tried, so I had to
install them from Sid. One of the -dev dependencies became clear when I
removed the redirection from /dev/null in the compile function at

b) I added /usr/include to the include path in SConstruct.

c) I added some include statements into some of the source code files,
for example:

 * include/Attribute.h
 * src/nebula/Log.cc
 * src/rm/RequestManager.cc
 * src/pool/PoolSQL.cc

Among them where vector, string.h and algorithm. My C++ proficiency is
zero, so this might well be my bad -- yet it worked. I was sloppy at
trying to look at the exact source of the problems, but I hope this helps.

OTOH, I'm working on a Debian package (for Sid and Lenny) for OpenNebula

Thanks for your time and great work,
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Users mailing list