<span style="font-family:;color:rgb(0,0,0);font-size:10.5pt">Hi 
everyone,I have found several problems when I use LVM datastore on 
OpenNebula3.8. </span>
<div><span style="font-family:;color:rgb(0,0,0);font-size:10.5pt">First,when I 
delete the image which is registed in the LVM datastore, OpenNebula doesn't 
remove the lv.</span></div>
<div><span style="font-family:;color:rgb(0,0,0);font-size:10.5pt">Following is error 
record written in the oned.log:</span></div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ReM][D]: Req:3040 UID:0 ImageDelete 
result SUCCESS, 7</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImG][D]: Message received: LOG I 7 rm: 
Removing localhost:/dev/-/- from the image repository</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImM][I]: rm: Removing localhost:/dev/-/- 
from the image repository</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImG][D]: Message received: LOG E 7 rm: 
Command " sudo lvremove -f -/-" failed: lvremove: invalid option -- '/'</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImM][E]: rm: Command " sudo lvremove -f 
-/-" failed: lvremove: invalid option -- '/'</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImG][D]: Message received: LOG I 7 Error 
during parsing of command line.</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImM][I]: Error during parsing of command 
line.</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImG][D]: Message received: LOG E 7 Error 
removing localhost:/dev/-/-</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImM][E]: Error removing 
localhost:/dev/-/-</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImG][D]: Message received: LOG I 7 
ExitCode: 3</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImM][I]: ExitCode: 3</div>
<div dir="ltr">Mon Oct 29 00:30:57 2012 [ImG][D]: Message received: RM FAILURE 7 
Error removing localhost:/dev/-/-</div>
<div style="margin-right:0px" dir="ltr">Mon Oct 29 00:30:57 2012 [ImM][E]: Error 
removing image from datastore. Manually remove image source - to completely 
delete the image: Error removing localhost:/dev/-/-</div>
<div dir="ltr"><strong><span style="font-family:Calibri;color:rgb(0,0,0);font-size:10.5pt"><span style="font-family:;font-size:10.5pt;font-weight:normal">This problem has 
happened 3 times when I delete 6 images.</span></span></strong></div><div><br></div>Oscar<br><br><br>