[one-users] NIC Hot Plug with OpenVSwitch

MENDOZA, John Robert T. bert at asti.dost.gov.ph
Sun Jul 14 20:17:12 PDT 2013

Hi Jon,

Thanks for the feedback.  I don't believe its an issue with libvirtd
versions, but with the utilities managing libvirt.  Opennebula can
already use the openvswitch bridges when defined in a VM xml
configuration file.

Upon inspection of the attach_nic script, we can see there that it's
using "virsh attach-inteface" while attach_disk uses "virsh
attach-device" and uses an xml config file as input. The virsh utility
does not support openvswitch bridges when specified in the command line

I'm seeing how we can device a workaround for this. Either we re-program
the attach_nic script to use "attach-device" or encapsulate the ovs
bridge as a libvirt network definition as suggested in the libvirt-users



On Sunday, 14 July, 2013 04:32 PM, Jon wrote:
> Hello John,
> I also get an error, see below.
> I'm on ubuntu 13.04 using libvirt 1.0.2 and ovs versions : 
> ovs-vswitchd (Open vSwitch) 1.9.0
> Compiled Mar  1 2013 14:34:38
> OpenFlow versions 0x1:0x1
> This is the relevant entry in my VM log:
> Sun Jul 14 02:19:17 2013 [VMM][I]: Successfully execute network driver
> operation: pre.
> Sun Jul 14 02:19:17 2013 [VMM][I]: Command execution fail:
> /var/tmp/one/vmm/kvm/attach_nic one-24 02:00:0a:2a:00:65 ovsbr0 - 24
> Sun Jul 14 02:19:17 2013 [VMM][E]: attach_nic: Command "virsh
> --connect qemu:///system attach-interface --domain one-24 --type
> bridge --source ovsbr0 --mac 02:00:0a:2a:00:65" failed: error: Failed
> to attach interface
> Sun Jul 14 02:19:17 2013 [VMM][I]: error: Unable to add bridge ovsbr0
> port vnet1: Operation not supported
> Sun Jul 14 02:19:17 2013 [VMM][E]: Could not attach NIC
> (02:00:0a:2a:00:65) to one-24
> Sun Jul 14 02:19:17 2013 [VMM][I]: ExitCode: 1
> Sun Jul 14 02:19:17 2013 [VMM][I]: Failed to execute virtualization
> driver operation: attach_nic.
> Sun Jul 14 02:19:17 2013 [VMM][E]: Error attaching new VM NIC: Could
> not attach NIC (02:00:0a:2a:00:65) to one-24
> The oned log basically echos the same.
> I have not tried to manually run the command though.
> I also migrated the vm to a different host just in case it was an ovs
> misconfig on the first host, but received the same error.
> Wondering if it's maybe just the version of libvirt we're using.
> This is really the first I've tested NIC hotplugging so please take my
> results with a grain of salt.
> Best Regards,
> Jon A
> On Sun, Jul 14, 2013 at 1:10 AM, MENDOZA, John Robert T.
> <bert at asti.dost.gov.ph <mailto:bert at asti.dost.gov.ph>> wrote:
>     Hi Everyone,
>     Hope everyone is doing ok. :)
>     Just want to ask if anybody has tried the NIC hot plug functionality
>     with OpenVSwitch.  I'm testing ONE 4.0.1 and am having error messages
>     pertaining to the creation of the virtual ports for the VMs.  It
>     outputs  "error: Unable to add bridge ovsbr0 port vnetX: Operation not
>     supported". I did some Google'ing and it seems that the virsh CLI
>     utility has not been updated to support OpenVSwitch bridges as it
>     still
>     treats the type bridge argument to be a linux bridge.  I'm thinking of
>     recoding the "attach_nic" script to create an xml file and use "virsh
>     attach-device" to hot plug the NIC the same way disk hot plugging is
>     done.  Any thoughts? Or is there something else I should know why ONE
>     used "attach-interface" in the first place?
>     Thanks,
>     John Robert Mendoza
>     _______________________________________________
>     Users mailing list
>     Users at lists.opennebula.org <mailto:Users at lists.opennebula.org>
>     http://lists.opennebula.org/listinfo.cgi/users-opennebula.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opennebula.org/pipermail/users-opennebula.org/attachments/20130715/1ce98a75/attachment-0002.htm>

More information about the Users mailing list