[one-users] Unable to Ping Migrated VM

Justin Cinkelj justin.cinkelj at xlab.si
Sun Jun 12 22:33:05 PDT 2011


I had (and still have) similar (same?) problem.
Machines n0007 (head and node) and n0008 ('compute' node only) have NFS
shared /var/lib/one directory. Working VMs can be created on both nodes.
VM 388 is running on n0008. Command
  onevm migrate 388 n0007
creates new kvm process on n0007, but then it is not possible to ping
the VM or to use virt-viewer (it is just connecting to VNC server). I
didn't notice any errors in opennebula log.
  ps afx output
/usr/bin/kvm -S -M pc-0.12 -cpu qemu32 -enable-kvm -m 512 -smp  ...
 \_ sh -c cat
     \_ cat
sh -c ssh -n n0007 '/usr/share/one/hooks/ebtables-kvm one-388' ; echo
ExitCode: $? 1>&2
 \_ ssh -n n0007 /usr/share/one/hooks/ebtables-kvm one-388

I tried migration with virsh, and
  virsh migrate --live one-387 qemu+ssh://n0008/session
worked (with or without --live option).

Next, I tried 
  onevm livemigrate
command, which works (after setting QEMU_PROTOCOL=qemu+ssh
 in /var/lib/one/remotes/vmm/kvm/kvmrc )

Any suggestion, at least how to pinpoint the problem? Maybe add
equivalent of bash 'set -x' to critical file or two?

Regards, Justin

More information about the Users mailing list