[one-users] Problems when booting VM (OpenNebula 2.0.1 and ESXi 4.1)

Matthias Keller mkeller at upb.de
Tue Feb 1 05:37:18 PST 2011

Dear Luigi,

referring to your last post today (01.02), I might help. We are in the same situation as we also trying to build up an Opennebula-Cloud with ESXi-Servers. After some headache about my low administration skills and about a bit unclear documentation on the website / configuration process, we figured out to launch VMs on esx-servers. As I'm not able to diagnose your described issues, I try to summaries our experiences:

- we had to reinstall our opennebula 2 installment, because system-wide installation /etc/oned.conf, etc. didn't work fully, because some scripts and especially scripts of the esx-drivers plugin. So our second try ends - as your installment - in /srv/cloud/one
- after new logging in ONE_LOCATION env was not set correctly, so we had to make sure it's written somewhere at .bashrc and changing user from root by using "su - oneadmin", this initializes the oneadmin-shell environment
- first we tried starting a vm without network to minimize the error-sources.
- we installed (in documentation mentioned) script-fix with sudo rights - this is need to change owner, so the oneadmin of esx is able to access it, in order to start your vm - I guess somewhere near "starting a vm" can your problem be solved. 
- the [image] esx volume should be the correct one (DATASTORE) and can be checked via vsphere client. the oneadmin has to have the same uid in esx and linux. We also checked this, by starting a placed VM by hand via vsphere client.
- describing Arch=i686 is necessarily (as you did).
- activate logging for VMM-Driver (because I assume your TM-Driver works properly):
if your oned.conf looks like:
#  VMware Driver Addon Virtualization Driver Manager Configuration
VM_MAD = [
    name       = "vmm_vmware",
    executable = "one_vmm_sh",
    arguments  = "vmware",
    default    = "vmm_sh/vmm_sh_vmware.conf",
    type       = "vmware" ]

than the file should contains the following input:
# Uncomment the following line to active MAD debug  

For every driver it should work with editing the following file - but I'm not really sure about that:

Logs are placed in /srv/cloud/one/var

Perhaps I could helped you,

Matthias Keller

More information about the Users mailing list