[one-users] unable to start a VM

Upendra Sharma upendras at hotmail.com
Sun Feb 1 11:06:07 PST 2009

Thanks Ruben,you clue helped me.Although I changed xen.rb to when 'max_free_memory'
         memory_info[:free]=columns[1].to_i*1024but realized that it was failing and then I found out that my "xm info" does not have max_free_memory (probably I have an older version of xen .. maybe buggy-version).so changed it to (total_memory - min_size_of_dom0).of-course, its a blunder and I need to find a better fix for that, but for now it works ... probably you can suggest a fix to me.currently the minimal setup is up and working, though I am facing some difficulty in suspending and resuming the VMs and in performing live migration the VMs. But that I think is not because of nebula, but is some trouble with xen.thanks again,-upendra > Date: Sun, 1 Feb 2009 13:22:42 +0100> From: rubensm at dacya.ucm.es> Subject: Re: [one-users] unable to start a VM> To: upendras at hotmail.com; users at lists.opennebula.org> > OK,> 	Yes, I agree that there should be an error message regarding the > misconfiguration with sudo. > > 	Regarding the pending VM: your hosts report 128MB of  Free Memory, an the > TestVM needs 256MB. This is probably because of you are using ballooning with > Xen. In this case, you can easily solve this, see:> > http://trac.opennebula.org/ticket/54> > This bug affects ballooning configurations in 1.0. Unfortunately, the patch is > not in 1.2.> > You can get more info about scheduling in the sched.log file (that one is C++ > ;)).> > Cheers> > Ruben> > On Sunday 01 February 2009 07:08:15 you wrote:>> Thanks Ruben,>>>> I eventually debugged that problem, but the VM is still not running>>>> What was the problem with "onehost list"?>> I found out that my sudo on destination machines (obelix41 and obelix43)>> required tty. So I disabled it (visudo and comment out requiretty) and now>> the result is as shown below onehost list>>  HID NAME                      RVM   TCPU   FCPU   ACPU    TMEM    FMEM>> STAT 0 obelix43                    0    800    799    800 4192256  130048  >> on 1 obelix41                    0    800    799    800 4192256  130048  >> on The Surprising thing is that although sudo was not working remotely>> there was no error reported in oned.log. Anyways, that seems to be clean>> now .... but the problem still remains.>>>> My VM is always on the STATUS of pending.>>>>  onevm list>>   ID     NAME STAT CPU     MEM        HOSTNAME        TIME>>    3   TestVM pend   0       0                 00 00:10:13>>>> I do not know what is happening now. None of the logs report any error. Is>> there is quick fix which you know  (the fact is that I do not know ruby).>> do you think that since this is a beta version so I have unearthed some>> untested portion of code and I should switch to the stable version, i.e.>> 1.0?>>>> thanks,>> -upendra>>>>> Date: Sun, 1 Feb 2009 00:43:51 +0100>>> From: rubensm at dacya.ucm.es>>> Subject: Re: [one-users] unable to start a VM>>> To: users at lists.opennebula.org>>> CC: upendras at hotmail.com>>>>>> Hi>>> 	It seems that the VMs are not deployed because the obelix nodes are not>>> reporting their status. From the onehost output, you can see that they do>>> not have any Available CPU (ACPU)>>>>>> 	This is usually a problem with ssh. You should have access two the nodes>>> without being prompt for a password. So at the front-end:>>> $ssh obelix41>>> should give you a shell at obelix41 (without asking nothing).>>>>>> 	You can get more details in oned.log. There should be something related>>> to ERROR Monitoring obelix...>>>>>> Cheers>>>>>> Ruben>>>>>> On Sunday 01 February 2009 00:05:11 Upendra Sharma wrote:>>>> Hi,>>>>>>>> I have downloaded OpenNebul -1.1.85>>>> I have installed it on CentOS 5.2>>>>>>>> I am trying to create a VM (using "onevm create myvm.tmp") but it>>>> returns the result is that the VM creation is always pending>>>>>>>> onevm list:>>>>   ID     NAME STAT CPU     MEM        HOSTNAME        TIME>>>>    2   TestVM pend   0       0                 00 00:00:20>>>>>>>>  onevm show TestVM>>>> VID            : 2>>>> UID            : 0>>>> STATE          : PENDING>>>> LCM STATE      : LCM_INIT>>>> DEPLOY ID      :>>>> MEMORY         : 0>>>> CPU            : 0>>>> LAST POLL      : 0>>>> START TIME     : 01/31 17:59:48>>>> STOP TIME      : 12/31 19:00:00>>>> NET TX         : 0>>>> NET RX         : 0>>>>>>>> ....: Template :....>>>>     CPU             : 1>>>>     DISK            :>>>> READONLY=no,SOURCE=/home/upendra/nebula/images/CentOS5.img,TARGET=sda>>>> MEMORY          : 256>>>>     NAME            : TestVM>>>>     NIC             :>>>> BRIDGE=eth0,IP=,MAC=00:03:c0:a8:f5:50,NETWORK=Public>>>> VLAN,VNID=0 OS              : BOOTLOADER=/usr/bin/pygrub>>>>>>>>>>>> I do not know what is the problem. I frankly do not know where to start>>>> the debugging from? Any help is appreciated.>>>>>>>> My cluster configuration is as follows: my cluster front-end is again a>>>> CentOS 5.2 machine with xen on it. I have added two more nodes on it>>>> (obelix41, obelix43) onehost list>>>>  HID NAME                      RVM   TCPU   FCPU   ACPU    TMEM    FMEM>>>> STAT 0 obelix41                    0             0    100>>>> on 1 obelix43                    0             0    100>>>> on>>>>>>>> Each of these machines are a quadcore dual-processor machine.>>>>>>>> thanks,>>>> -upendra>>>>>>>> tha>>>>>>>>>>>> _________________________________________________________________>>>> Chose your Life Partner! Join MSN Matrimony FREE>>>> http://www.in.msn.com/matrimony>>>>>> -->>> +---------------------------------------------------------------+>>>  Dr. Ruben Santiago Montero>>>  Associate Professor>>>  Distributed System Architecture Group (http://dsa-research.org)>>>>>>  URL:    http://dsa-research.org/doku.php?id=people:ruben>>>  Weblog: http://blog.dsa-research.org/?author=7>>>>>>  GridWay, http://www.gridway.org>>>  OpenNEbula, http://www.opennebula.org>>> +---------------------------------------------------------------+>>>> _________________________________________________________________>> Plug in to the MSN Tech channel for a full update on the latest gizmos that>> made an impact. http://computing.in.msn.com/> > -- > +---------------------------------------------------------------+>  Dr. Ruben Santiago Montero>  Associate Professor>  Distributed System Architecture Group (http://dsa-research.org)> >  URL:    http://dsa-research.org/doku.php?id=people:ruben>  Weblog: http://blog.dsa-research.org/?author=7>              >  GridWay, http://www.gridway.org>  OpenNEbula, http://www.opennebula.org> +---------------------------------------------------------------+> 
Wish to Marry Now? Join MSN Matrimony FREE!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opennebula.org/pipermail/users-opennebula.org/attachments/20090201/98e2cbd0/attachment-0002.htm>

More information about the Users mailing list