[one-users] libwwwhttp.so: undefined reference to`MD5Init', `MD5Final' and `MD5Update'

Alvaro Canales accleo at gmail.com
Thu Jun 19 10:32:59 PDT 2008


That definitely solved my problem! :D I successfully installed ONE.

Before you gave me this answer, I had thought many workarounds:
Since I thought this error was probably w3c-libwww-5.4.0 library related, I
decided to build xmlrpc-c-1.06.27 without libwww support (notice that
OpenNebula has not libwww as a requirement!). Moreover, libwww and curl can
be considered very similar, I already have curl installed and xmlrpc doesn't
have it as a prerequisite. But when I tried to install ONE, I got another
error regarding a libwww library not present. I think it expected me to have
libwww installed. I recommend then, to put libwww as a requirement, too.

By the way, congratulations for the new release and thanks again for your

On Thu, Jun 19, 2008 at 12:27 PM, Javier Fontan <jfontan at fdi.ucm.es> wrote:

> Hello,
> Seems that we forgot to add libmd5 to the list of libraries needed by the
> scheduler. We are about to change that, meanwhile you can add this library
> yourself.
> In http://trac.opennebula.org/browser/trunk/src/scheduler/SConstruct#L62
> you have to add 'md5' after 'm' line so it looks like this:
> --8<------
>    'wwwtrans',
>    'wwwcore',
>    'wwwutils',
>    'm',
>    'md5'
> ])
> # Build tests
> for sched in scheduler_names:
>        env.Program(sched, sched+'.cc')
> ------>8--
> Sorry for this mistake.
> Could you please tell us what linux distro are you using? It is just to
> have more information on how one building works in different flavors, not
> related with the problem you are having.
> Bye
> On Jun 19, 2008, at 11:38 AM, Alvaro Canales wrote:
>  Hello again,
>> I don't know if it is open nebula related, but when I try to install ONE,
>> I get this error:
>> g++ -o src/scheduler/mm_sched.o -c -g -Wall -Iinclude
>> -I/OVS/software/include src/scheduler/mm_sched.cc
>> g++ -o src/scheduler/mm_sched src/scheduler/mm_sched.o -Lsrc/common
>> -Lsrc/host -Lsrc/mad -Lsrc/nebula -Lsrc/pool -Lsrc/template -Lsrc/vm
>> -Lsrc/vmm -Lsrc/lcm -Lsrc/tm -Lsrc/dm -Lsrc/im -Lsrc/rm -L/OVS/software/lib
>> -Lsrc/scheduler -lsqlite3 -lnebula_scheduler -lnebula_core -lnebula_host
>> -lnebula_vm -lnebula_pool -lnebula_template -lnebula_common -lcurl
>> -lxmlrpc_client++ -lxmlrpc_client -lxmlrpc++ -lxmlrpc -lxmlrpc_util
>> -lxmlrpc_xmlparse -lxmlrpc_xmltok -lwwwxml -lxmltok -lxmlparse -lwwwzip
>> -lwwwinit -lwwwapp -lwwwtelnet -lwwwhtml -lwwwnews -lwwwhttp -lwwwmime
>> -lwwwgopher -lwwwftp -lwwwfile -lwwwdir -lwwwcache -lwwwstream -lwwwmux
>> -lwwwtrans -lwwwcore -lwwwutils -lm
>> /OVS/software/lib/libwwwhttp.so: undefined reference to `MD5Init'
>> /OVS/software/lib/libwwwhttp.so: undefined reference to `MD5Final'
>> /OVS/software/lib/libwwwhttp.so: undefined reference to `MD5Update'
>> collect2: ld returned 1 exit status
>> scons: *** [src/scheduler/mm_sched] Error 1
>> scons: building terminated because of errors.
>> I have no clue about what is going wrong, since I think w3c-libwww-5.4.0
>> library is properly installed and there is no much information in the
>> Internet.
>> If I do:
>> $ nm /OVS/software/lib/libwwwhttp.so | grep MD5
>>         U MD5Final
>>         U MD5Init
>>         U MD5Update
>> Which was expected output, but still don't know how to solve it.
>> Any help?
>> Thanks in advance!
>> --
>> Álvaro
>> _______________________________________________
>> Users mailing list
>> Users at lists.opennebula.org
>> http://lists.opennebula.org/listinfo.cgi/users-opennebula.org
> --
> Javier Fontan, Grid Technology Engineer/Researcher
> DSA Research Group: http://dsa-research.org
> Globus GridWay Metascheduler: http://www.GridWay.org
> OpenNebula Virtual Infrastructure Engine: http://www.OpenNebula.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opennebula.org/pipermail/users-opennebula.org/attachments/20080619/11105039/attachment-0003.htm>

More information about the Users mailing list