[one-users] Recover vm from wrong state pitfall

Jonathan Kelley jkelley at vm-labs.com
Tue Sep 21 07:04:37 PDT 2010

I tried the livemigrate option to onevm in my ESXi configuration and found
that I got this error:

Tue Sep 21 09:45:49 2010 [VMM][D]: Message received: MIGRATE FAILURE null
Action not implemented.

Now my VM is stuck in the migrate state and I can't run any of the onevm
commands to recover it. Is it a lost vm?

root at vmlvsa251:~# /srv/cloud/one/bin/onevm suspend 32
Error: Wrong state to perform action
root at vmlvsa251:~# /srv/cloud/one/bin/onevm list
   ID     USER     NAME STAT CPU     MEM        HOSTNAME        TIME
   27 oneadmin VMwareVM fail   0       0 12core.boston.v 00 00:04:33
   28 oneadmin VMwareVM fail   0     110 12core.boston.v 00 04:57:36
   31 oneadmin    XPDev fail   0     238 12core.boston.v 00 00:10:21
   32 oneadmin XPDevTes migr   0      46 intel2u1.boston 04 18:50:23

Also once my VM is in shutdown state is that the end of it's lifespan or can
I run it again somehow?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opennebula.org/pipermail/users-opennebula.org/attachments/20100921/5236cb43/attachment-0002.htm>

More information about the Users mailing list